Workflow Run History issues in Western US Region

Incident Report for Qualtrics

Resolved

This issue has been resolved.
Posted Sep 04, 2025 - 00:46 UTC

Investigating

We are currently investigating an issue with workflow run histories displaying in the Western US Region. Workflows are still running, but users may not be able to view workflow run histories starting from Sept. 3rd during this time.
Posted Sep 03, 2025 - 22:45 UTC
This incident affected: Workflows.