EX Participant Import Issues in the European Region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Sep 18, 2023 - 17:05 UTC

Investigating

We are currently investigating an issue with EX participant import delays in the European region.
Posted Sep 18, 2023 - 16:01 UTC
This incident affected: Administration.