Online Review Management issues in All Regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Feb 19, 2026 - 20:43 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 18, 2026 - 10:26 UTC

Update

We are ingesting new reviews but synchronisation of historical reviews is currently disabled due to issues on the google side.
Posted Feb 18, 2026 - 10:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2026 - 17:01 UTC

Investigating

We are currently investigating an issue with Online Review ingestion and processing for Connect to Google Places ORM Projects in All Regions due to issues with Google's APIs.
Posted Feb 17, 2026 - 15:43 UTC
This incident affected: Data Processing.