Report export issues in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Mar 15, 2023 - 21:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 21:09 UTC

Investigating

We are currently investigating an issue with exporting reports in all regions.
Posted Mar 15, 2023 - 21:01 UTC
This incident affected: Reports.