Survey taking and survey building issues in the European region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Sep 21, 2023 - 09:02 UTC

Investigating

We are currently investigating issues with survey taking and survey building in the European region
Posted Sep 21, 2023 - 07:55 UTC
This incident affected: Surveys (Survey Taking, Survey Editing).