Email Distribution issues in the Eastern US Region
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted Oct 18, 2024 - 05:17 UTC
Update
We are continuing to investigate this issue.
Posted Oct 18, 2024 - 05:15 UTC
Investigating
We are currently investigating increased bounce rates across email distributions in the Eastern US Region. Some distributions sent from the Eastern US Region using Qualtrics domains may bounce.
Posted Oct 18, 2024 - 04:21 UTC
This incident affected: Distributions (Email).