Discover Connectors related issues in UK environment

Incident Report for Qualtrics

Resolved

Incident is resolved.
Posted Aug 18, 2026 - 23:37 UTC

Monitoring

A fix has been implemented and we are monitoring the result.
Posted Aug 18, 2026 - 23:37 UTC

Investigating

Discover Connectors UI and API endpoints for UK environment inaccessible. Ingestion not using API is not affected. Issue is under investigation.
Posted Aug 18, 2026 - 22:02 UTC
This incident affected: Data Processing.