Website / App Feedback issues in the Eastern US region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Nov 17, 2024 - 05:15 UTC
Investigating
We are currently investigating an issue with contact frequency enabled intercepts in the Eastern US region. Contact frequency enabled intercepts may not be displaying for some users.
Posted Nov 17, 2024 - 00:51 UTC
This incident affected: Website / App Insights (Visitor Intercept Display).