Data Processing Delays in Eastern US Region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Nov 04, 2024 - 04:37 UTC
Investigating
We are currently investigating an issue with Data Processing in the Eastern US Region for new/updated responses showing up in Dashboards and Data & Analysis. No data has been lost and the system should be caught up shortly.
Posted Nov 04, 2024 - 02:30 UTC
This incident affected: Data Processing.