Distribution issues in all Regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 15:36 UTC

Identified

We identified an issue with email deliverability for Microsoft inboxes. Email distributions may take longer than usual to reach recipients who use Microsoft services.
Posted Sep 04, 2026 - 13:25 UTC
This incident affected: Distributions (Email).