Issues in creating and updating tickets in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Apr 28, 2026 - 16:08 UTC

Update

We have identified and currently investigating an issue with triggering workflows based on ticket events in all regions.
Posted Apr 28, 2026 - 14:28 UTC

Investigating

We are currently investigating a latency with creating and updating tickets in all regions.
Posted Apr 28, 2026 - 12:36 UTC
This incident affected: Workflows and Tickets.