Issues with creating support tickets in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Sep 26, 2025 - 20:42 UTC

Investigating

We are currently investigating issues with our ticketing system. Chats currently are unable to be placed and there will be a delay in responses to phone calls. Our team is actively working on a resolution as quickly as possible. We apologize for any inconvenience this may cause.
Posted Sep 26, 2025 - 19:54 UTC
This incident affected: Support (Live Support).