Platform, Studio, and Discover connector issues in the Eastern US region

Incident Report for Qualtrics

Resolved

This issue has been resolved.
Posted Oct 21, 2025 - 08:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 07:42 UTC

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 07:32 UTC

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 06:07 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 21:07 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 19:22 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 18:40 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:21 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:13 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 14:05 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 13:55 UTC

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 13:54 UTC
This incident affected: Surveys (Survey Taking, Survey Editing), Distributions (Email, SMS (Text)), XM Directory & Contacts (XM Directory Automations, XM Directory Imports, Directory Contacts), Discover Studio (Endpoint: https://cxstudio.clarabridge.net/dashboard/, US Endpoint: https://studio.us1.qualtrics.io/dashboard/), Support (Live Support), and Logins, Data Processing, Projects, Administration, Dashboards, Reports, Workflows, Ticketing, API / Developer Platform, Stats iQ & Text iQ.