360 Project Distribution issues in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Feb 16, 2025 - 10:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 16, 2025 - 09:45 UTC

Investigating

We are currently investigating an issue with sending some 360 distributions in all regions.
Posted Feb 16, 2025 - 09:40 UTC
This incident affected: Distributions (Email).