SMTP distribution delay issue in the Canadian region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted May 05, 2026 - 02:55 UTC

Investigating

We are currently investigating an issue with SMTP distribution delays in the Canadian region.
Posted May 05, 2026 - 02:26 UTC
This incident affected: Distributions (Email).