Degraded Performance across the European region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Sep 13, 2023 - 10:09 UTC

Investigating

We are currently investigating an issue degraded performance in the European. Latency and failures possible in most actions and login failures may occur.
Posted Sep 13, 2023 - 09:40 UTC
This incident affected: Surveys (Survey Taking, Survey Editing), Distributions (Email, SMS (Text)), Website / App Insights (WAI Project Editing), and Logins, Data Processing, Projects, Administration, Dashboards, Reports, Workflows, Ticketing, API / Developer Platform, Stats iQ & Text iQ.