Website / App Feedback statistics issues in all regions
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 18:44 UTC
Investigating
We are currently investigating an issue with loading Website / App Feedback statistics in all regions.
Posted Nov 18, 2022 - 17:47 UTC
This incident affected: Website / App Insights (WAI Project Editing).