Text iQ latency in the Canadian region.
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Jun 29, 2022 - 21:40 UTC
Investigating
We are currently investigating an issue with Text iQ latency in the Canadian region.
Posted Jun 29, 2022 - 13:45 UTC
This incident affected: Stats iQ & Text iQ.