Discover data processing issues in the European region

Incident Report for Qualtrics

Resolved

Recovery is completed.
Posted Feb 28, 2025 - 21:07 UTC

Monitoring

Issue is fixed and recovery is in progress. We are also monitoring for any further issues.
Posted Feb 28, 2025 - 16:07 UTC

Investigating

We are investigating a data processing issue in the European region.
Posted Feb 28, 2025 - 15:56 UTC
This incident affected: Data Processing.