Discover Studio — US Region Outage

Incident Report for Qualtrics

Resolved

This incident has resolved
Posted Apr 07, 2026 - 11:47 UTC

Update

We are continuing to investigate this issue.
Posted Apr 07, 2026 - 10:19 UTC

Investigating

Discover Studio for US Region is experiencing 504 Gateway errors. We are currently investigating the issue.
Posted Apr 07, 2026 - 10:15 UTC
This incident affected: Discover Studio (US Endpoint: https://studio.us1.qualtrics.io/dashboard/).