Survey Builder issue in All Regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 04:10 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 10, 2025 - 03:50 UTC

Investigating

We are currently investigating an issue where the Survey Builder is only displaying in English, regardless of the user's account language settings.
Posted Mar 10, 2025 - 03:49 UTC
This incident affected: Surveys (Survey Editing).