Dashboard access and support request submission issues in multiple regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 09:58 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:58 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:20 UTC

Investigating

We are currently investigating an issue with dashboards loading and customer support in multiple regions.
Posted Oct 20, 2025 - 08:10 UTC
This incident affected: Support (Live Support) and Dashboards.