Workflows Triggering delay in European region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Nov 05, 2025 - 11:26 UTC

Investigating

We are currently investigating delays in workflows triggering in European region.
Posted Nov 05, 2025 - 11:19 UTC
This incident affected: Workflows.