Workflow issues in Eastern US region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 04:02 UTC

Investigating

We are currently investigating an issue with workflow in Eastern US regions. Please note that no workflow executions are delayed or impacted and this only impacts workflow history.
Posted Jul 30, 2025 - 03:29 UTC
This incident affected: Workflows.