Intermittent issues with CX Studio

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Nov 08, 2025 - 05:24 UTC

Investigating

CX Studio is experiencing issues intermittently. Started around 4:30 PM EST.
Studio dashboards widgets, access to connectors and designer may not be available.
Posted Nov 08, 2025 - 05:01 UTC
This incident affected: Discover Studio (Endpoint: https://cxstudio.clarabridge.net/dashboard/).