Contact import issues in Eastern US region
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 23:03 UTC
Update
We are continuing to monitor the performance of XM Directory contact imports.
Posted Aug 10, 2022 - 21:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2022 - 00:17 UTC
Investigating
We are currently investigating an issue with importing contacts in the Eastern US region.
Posted Aug 09, 2022 - 22:01 UTC
This incident affected: XM Directory & Contacts (XM Directory Imports).