Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 08, 2024 - 06:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 08, 2024 - 06:00 UTC
Scheduled
We will be performing scheduled maintenance in the Eastern US region on Sunday, December 8th, 2024 from 1 AM to 2 AM EST. During this maintenance window, customers in the Eastern US region may not be able to access the Qualtrics platform, and all services in the region will be intermittently available. Any scheduled survey and email distributions will be delayed and resume once maintenance is complete.
Posted Dec 02, 2024 - 20:06 UTC
This scheduled maintenance affected: Surveys (Survey Taking, Survey Editing), Distributions (Email, SMS (Text)), XM Directory & Contacts (XM Directory Automations, XM Directory Imports, Directory Contacts), Website / App Insights (WAI Project Editing, Session Replay, Visitor Intercept Display), and Logins, Data Processing, Projects, Administration, Dashboards, Reports, Workflows, Ticketing, API / Developer Platform, Stats iQ & Text iQ.