Discover Studio and Designer intermittent issues

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:54 UTC

Monitoring

All components are up and stable. We are monitoring it.
Posted Nov 18, 2025 - 13:27 UTC

Identified

The issue has been identified due to Cloudflare issue and awaiting a response from Cloudflare.
Posted Nov 18, 2025 - 12:51 UTC
This incident affected: Discover Studio (Endpoint: https://cxstudio.clarabridge.net/dashboard/).