Response ingestion delays in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Feb 18, 2026 - 22:17 UTC

Monitoring

We were experiencing issues with delays in new responses being accessible on dashboards/reports/data & analysis as well as delays in reindexing jobs. A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 20:50 UTC
This incident affected: Data Processing.