Email distribution latencies in Western US region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 09:23 UTC

Investigating

We are currently investigating an issue causing latencies of up to an hour in email distributions in the Western US Region.
Posted Feb 27, 2025 - 16:55 UTC
This incident affected: Distributions (Email).