Discover Dashboard slowness and Data ingestion issue in US region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 18:50 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 09, 2026 - 18:32 UTC

Investigating

We are seeing issue with the some of our US region environments which is causing Discover dashboard slowness and intermittent data ingestion issues. We are currently investigating it.
Posted Jul 09, 2026 - 18:14 UTC
This incident affected: Discover Studio (US Endpoint: https://studio.us1.qualtrics.io/dashboard/).