View this page inView invia

beta

Issues with Distributions in all regions.
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted 2 years ago. Mar 22, 2023 - 15:18 UTC
Investigating
We are currently investigating an issue with some distributions not being delivered or containing unreadable data for brands with data isolation enabled in all regions.
Posted 2 years ago. Mar 22, 2023 - 11:45 UTC
This incident affected: Distributions (Email).