Qualtrics Social Connect issues in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted May 09, 2025 - 19:38 UTC

Investigating

Qualtrics Social Connect is experiencing an issue with ingesting mentions from X (formerly Twitter) for all regions. During this time, customers will not be able to view / post X mentions using Social Connect.
Posted May 09, 2025 - 17:47 UTC
This incident affected: Qualtrics Social Connect (External Issue).