Distribution issues in the Eastern US region
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 03:45 UTC
Investigating
We are currently investigating an issue with distributions in the Eastern US region. Email distributions may be delayed and some email tasks may be failing.
Posted Jul 19, 2024 - 06:33 UTC
This incident affected: Distributions (Email).