Data processing issues in Eastern US region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Apr 16, 2024 - 01:02 UTC
Investigating
We are currently investigating a delay with reindexing data in Data & Analysis and dashboards in the Eastern US region.
Posted Apr 15, 2024 - 23:26 UTC
This incident affected: Data Processing and Dashboards.