XM Directory and distribution issues in the European region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Sep 17, 2023 - 21:04 UTC

Update

The impact to distributions has been resolved.
Posted Sep 17, 2023 - 20:34 UTC

Investigating

We are currently investigating an issue that is causing XM directory pages to load slowly or timeout, distributions to be sent slowly or fail, and some searches in XM directory may fail or timeout in the European region. This began at 12:15 PM MT.
Posted Sep 17, 2023 - 20:13 UTC
This incident affected: Distributions (Email, SMS (Text)) and XM Directory & Contacts (Directory Contacts).