Discover File Connectors are experiencing issues in multiple regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 06:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted Mar 25, 2026 - 02:57 UTC

Update

We are continuing to investigate this issue.
Posted Mar 24, 2026 - 16:39 UTC

Investigating

Discover File Connectors are failing and experiencing issues for Qualtrics-Owned SFTP Servers. We are currently investigating this.
Posted Mar 24, 2026 - 16:04 UTC
This incident affected: Discover Studio (Endpoint: https://cxstudio.clarabridge.net/dashboard/).