Email distribution issues in the European region, Western US region, and Canadian region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Jun 09, 2025 - 12:42 UTC

Update

We are continuing to investigate the issue. Additional impact detected in the Eastern US region.
Posted Jun 08, 2025 - 17:47 UTC

Investigating

We are currently investigating an issue with email distributions in the European region, Western US region, and Canadian region. Some email distributions are experiencing increased bounce rates. Impacted recipients can be found in the distribution history.
Posted Jun 08, 2025 - 14:14 UTC
This incident affected: Distributions (Email).