Discover Connector related issues in some US region Environments

Incident Report for Qualtrics

Resolved

The incident is resolved, and recovery is underway.
Posted Jun 02, 2025 - 20:55 UTC

Monitoring

Job are working fine now and we are monitoring it.
Posted Jun 02, 2025 - 19:50 UTC

Investigating

We are seeing Discover Connectors related issues. We are investigating this.
Posted Jun 02, 2025 - 18:40 UTC
This incident affected: Discover Studio (Endpoint: https://cxstudio.clarabridge.net/dashboard/).