Distribution delays in the European region
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 13:54 UTC
Investigating
We are currently investigating an issue with distribution delays in the European region.
Posted Nov 12, 2024 - 10:41 UTC
This incident affected: Distributions (Email).