Supplemental Data Source issues in all regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 03:11 UTC

Investigating

We are currently investigating an issue with Supplemental Data Source data not pulling into surveys in all regions
Posted Jul 29, 2026 - 02:23 UTC
This incident affected: Surveys (Survey Taking).