XM Directory latency issues in the European region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Sep 20, 2023 - 11:57 UTC

Investigating

We are currently investigating increased latency in XM Directory in the European region
Posted Sep 20, 2023 - 11:24 UTC
This incident affected: XM Directory & Contacts (Directory Contacts).