Issues with action planning, ticket reporting, and deleting responses in the Eastern US Region
Incident Report for Qualtrics
Resolved
This issue has been resolved.
Posted Oct 16, 2024 - 22:15 UTC
Investigating
We are currently investigating issues with ticket reporting, survey response deletion, and EX Action Plan data in the Eastern US region.
Posted Oct 16, 2024 - 21:56 UTC
This incident affected: Data Processing, Dashboards, and Ticketing.