Intermittent Discover Dashboard and Export api Issue

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Sep 22, 2026 - 18:48 UTC

Monitoring

A fix has been implemented and we are monitoring it currently.
Posted Sep 22, 2026 - 17:53 UTC

Investigating

Some of our US region environments are experiencing intermittent Discover Dashboard and Export api issues. We are currently investigating this.
Posted Sep 22, 2026 - 16:16 UTC
This incident affected: Discover Studio (Endpoint: https://cxstudio.clarabridge.net/dashboard/).