XM Directory issues in Canadian Region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Nov 08, 2025 - 14:10 UTC

Investigating

We are currently investigating an issue with viewing recently created or updated contacts in the Canadian Region.
Posted Nov 08, 2025 - 13:57 UTC
This incident affected: XM Directory & Contacts (Directory Contacts).