Scheduled Response Report Email issues in all regions
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Oct 16, 2024 - 13:34 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 16, 2024 - 10:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2024 - 10:14 UTC
This incident affected: Reports.