XM Directory issues in Eastern US Region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Nov 06, 2025 - 05:09 UTC

Update

We are continuing to investigate this issue. We are also seeing impact in creating distributions via the public API.
Posted Nov 06, 2025 - 00:58 UTC

Update

We are continuing to investigate this issue. We are also seeing impact to SMS distributions.
Posted Nov 06, 2025 - 00:49 UTC

Investigating

We are currently investigating an issue with the XM Directory and related workflow tasks in the Eastern US Region.
Posted Nov 06, 2025 - 00:30 UTC
This incident affected: Distributions (SMS (Text)), XM Directory & Contacts (Directory Contacts), and Workflows, API / Developer Platform.