Organisational hierarchy issue in multiple regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Jun 10, 2026 - 04:05 UTC

Investigating

We are currently investigating an issue with organisational hierarchy not loading in multiple regions.
Posted Jun 10, 2026 - 02:03 UTC
This incident affected: Dashboards.