Discover studio dashboards not loading for FRA studio

Incident Report for Qualtrics

Resolved

The issue has been resolved. The impact should be mitigated now.
Posted 1 month ago. May 08, 2025 - 10:27 UTC

Update

Discover FRA1 studio dashboards are facing intermittent issue while loading
Posted 1 month ago. May 08, 2025 - 10:00 UTC

Investigating

We are currently investigating this issue.
Posted 1 month ago. May 08, 2025 - 09:57 UTC
This incident affected: Discover Studio (EU Endpoint: https://studio.fra1.qualtrics.com/dashboard/).