Discover - Dashboard Data visualization, Designer and Connectors Unavailable

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 22:45 UTC

Monitoring

CA1 Accounts are now operational.
Posted Jun 30, 2026 - 22:39 UTC

Identified

AUS1 Accounts are now operational. In progress for CA1.
Posted Jun 30, 2026 - 22:36 UTC

Update

We are continuing to investigate this issue.
Posted Jun 30, 2026 - 22:25 UTC

Investigating

We are currently investigating an issue with Dashboard Data viewing, Connectors and Designer being unavailable in XM Discover CA1 and AUS1.
Posted Jun 30, 2026 - 22:24 UTC
This incident affected: Discover Studio (Canada Endpoint: https://studio.ca1.qualtrics.io/dashboard/, ANZ Endpoint: https://studio.aus1.qualtrics.io/dashboard/).